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 Basic Crystal Reports Writing Course Guide
Introduction To Crystal Report Writing 
Using 
This training course introduces you to Crystal Reports v7.0, the leading 
database report writer published by Seagate Software. Crystal Reports v7.0 is 
the report writer included with your Express Options v3.6 software.  Even 
though the  system is fully integrated with menu-driven 
reports for your stock administration needs, Crystal Reports gives you the 
ability to edit existing reports or create new reports that reflect your 
company�s information needs and graphic style.

This is a basic seminar, and previous experience or prerequisites are not 
necessary for your participation.  This course manual provides objectives, 
outlines key features of Crystal Reports, and offers integrated hands-on 
workshops throughout the day to complement your understanding of the 
software.

After you complete this course, it is recommended that you enroll in 
Advanced Crystal Report Writing course to further enhance 

your experience and expertise with the software.  Your instructor can discuss 
the course and provide a registration form if you are interested in enrolling or 
desire more information.  You can also contact s education 
department or visit our website for additional information on all training 
courses .

During this course, we will cover the following objectives:
� General Navigation through Crystal Reports.
� Introduction to Designing a Crystal Report.
� Inserting Fields (including Text Object, Special, Database, Formula, and 

Parameter).
� Subtotaling and Grand Totaling Numeric Fields.
� Inserting Lines and Bitmaps.
� Filtering Records.
� Handling Crystal Reports through the Express Options system.
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Create / Modify a Report

Crystal Reports is accessible through the  system. Thus, you 
will need to log in to the  system using your User Name and 
Password before you can start designing a Crystal Report.

Once you have launched the  system and logged on,
select the Crystal Reports button from the tool bar  and select the

Create / Modify a Report option.

Note: You can also select to Execute a Report (page 34).  This 
entails opening and running an existing report. We will 
return to this option once our Crystal Report is designed.

Launching Crystal 
Reports
June 2001 DRAFT 2
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The Seagate Crystal Reports window (shown below) opens.  Select New 
Report.

The Report Gallery window opens.  Click the Custom button in the lower 
right hand corner to open the second part of the Report Gallery window 
(shown below).

Under the Choose Report Type and Data Type section, select SQL/ODBC.

The Log On Server window opens.  For this course, scroll down to select 
ODBC - EOWin and select OK.  Note that your selection depends upon how 
your software is installed (i.e., Microsoft SQL Server, Oracle Server, etc.)  
Thus, the initial windows you encounter in this book and class may differ 
slightly from the windows you encounter at your office.
June 2001 DRAFT 3
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The Connect to SQL Anywhere window opens.  Type your User ID and tab 
to the Password field.  Type your Password and select OK or press Enter.  
Remember that this window will differ if you are using an environment other 
than SQL Anywhere.  See your database administrator if you have questions 
about your database type.

The Choose SQL Table window opens.  From this window you will select 
the first data table to be included in your report.  Note that there is a DBA 
prefix before each type of table.  This is the ID that was used when the 

 database was created.  Yours may be slightly different.  In 
addition, there will be ESPWin tables if the ESPWin system is also installed.

For today�s course, under SQL Tables, Select DBA.optionee and press Enter 
or select OK.
June 2001 DRAFT 4
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The Crystal Reports designing window opens.  Note that there are drop- 
down menus (File, Edit, View, etc.) listed across the top.  There are also 
shortcut icons on the tool bar beneath the drop-down menus.  

There are five basic navigation tools to help you design a Crystal Report:

Menu Bar: Provides drop-down access to Crystal options

Tool Bar: Contains icons (buttons) for the most frequently-used menu 
options.

Format Bar: allows you to apply formatting (e.g. bold, italics) to fields in 
your report.
Note that you can also right-click your mouse to format fields in your report.  There will be 
more explanation of formatting procedures xxx.

Status Bar: hints about menu items and tool bar the tool bar when they are 
active.

Note that this page opens with a Design tab and five basic fields (Report 
Header, Page Header, etc.)  You use these fields to populate your Crystal 
Report.  Below is a brief description of the five fields that are included by 
default:

Report Header: appears once on the first page of your report.

Page Header: repeats one time on every report page.

Details: area to place fields of data to populate the bulk of your report.

Report Footer: appears once on the last page of your report.

Page Footer: repeats at the bottom of every report page.

Note that you can adjust the relative size of any of these fields by putting 
your mouse on the line dividing the fields and dragging it horizontally up or 
down to resize each field.
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The Insert Fields window is also displayed on this design window, and is 
used to select and drag specific data fields into your report.  
Note that it is recommended that you bring in database tables one at a time to avoid linking 
issues (see page 18).  Since you selected DBA.optionee, all the fields within Express 
Option�s optionee table are displayed in this window.

Before you insert fields in your report, however, there are certain system 
defaults that need to be checked and possibly modified.  

Getting Started/Preparing to Design a 
Crystal Report
Before you start designing a Crystal Report, there are certain options that 

 recommends verifying or modifying for ease of design.  The 
selections that you make will apply to all Crystal Reports that you run, not 
just for the report you are designing in today�s course.

Select the File menu and Options.  The Options window opens with the 
Layout tab displayed.  

Menu Bar

Tool Bar

Format Bar

Status Bar
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Appendix

Data Dictionary (Excerpt)
This Data Dictionary excerpt contains the names of tables and views that make up the Exercise, 
Grant, Location,, Optionee, and Subsidiary databases for the  system. 

Table names are referenced on the left, the specific column or field name in the middle and then 
a description of the field on the right.  If a view is being described, the description of the field 
will be the actual table and column that the view is referencing for that field.

Note: This is only a portion of the entire dictionary. For the entire 
dictionary, please refer to the Microsoft Word file contained on 
your  software CD.

DATA DICTIONARY�EXCERPT

ENTITY / 
TABLE NAME COLUMN NAME ATTRIBUTE DEFINITION

EXERCISE ACTIV_DT Last edit of record.

EXERCISE USER_ID User ID used for last edit of record.

EXERCISE DEL_FLAG Transient field used in the processing of deletions. Field 
Value = 0.

EXERCISE EXER_ID Identifier to identify an exercise. An Exercise ID is 
created for each exercise.

EXERCISE MKT_PRC This is the Fair Market Value (FMV) on exercise date. If 
entered on-line, this value is populated from that. If you 
don't enter on-line, it gets populated from the FMV in 
the price table.

EXERCISE SWAP_PRC Only Stock Swap Exercises. The swap price of the 
shares swapped or the actual sale price on the date of 
the exercise. If NQ Stock Swap, SwapPrice = 
MarketPrice.

EXERCISE PRE_MPRC The previous market price before the last stock split.

EXERCISE CASH_DUE Only Stock Swap Exercises Exercises. This field is 
calculated by (Option Cost - (SharesSwapped * 
OptionPrice)). Can be overridden by user.

EXERCISE BROKR_CD The broker that did the exercise. = 
BROKECD.ITEM_CD

EXERCISE IADDR_NUM EQ ADDRESS.ADDR_NUM Issue to name and 
address for share registration.
June 2001 36
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This glossary is an excerpt from the Crystal Reports help system glossary (v7.0.1.200). 

To view the entire glossary:

1. Start the Express Options system, select the Crystal Reports icon.

2.  Select Create/Modify a Report to start the Crystal Reports software.

3. From the Help menu, select Segate Crystal Reports Help > Glossary.

B
Bitmap: A graphic file that can be added to a report.

C
Case sensitive: Case sensitive means that a program differentiates between uppercase and 
lowercase letters when evaluating a text string. Thus, a case-sensitive search for the word 
"house" will return only the value "house", but a non-case-sensitive search will return "house", 
"House", "HOUSE", and similar mixed-case strings. Seagate Crystal Reports operators (Equal, 
In string, etc.) are case-sensitive.

Column: A column is the display of data from a single field or formula. Columns run up and 
down the page. The words column and field are sometimes used interchangeably in the 
documentation. Compare with Row.

Comments: Comments are blocks of descriptive text that accompany formulas. Seagate Crystal 
Reports ignores comments when it runs the formula.

Glossary
June 2001 46
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Concatenate: To concatenate is to join two or more text strings together to form a single 
contiguous string.

Condition: In an If-Then-Else formula, the condition is the If part of the formula, the set of 
circumstances that must take place (be true) to trigger the Then (or consequence) part of the 
formula. In the formula If x<5 Then x Else 5, the expression x<5 is the condition.

Conditional Formatting: Conditional formatting is formatting that applies only if certain 
situations occur. For example, you can conditionally format numeric database fields to display 
in red when negative.

Conditional Formatting Formulas: Conditional formatting formulas are expressions that apply 
specific attributes to objects or sections only if certain criteria is met.

D
Database: A database is a bank of related data. Each unit (record) of the database is typically 
organized in a fixed format to make it easier to retrieve selected portions of the data on demand. 
Each record is made up of one or more data fields, and each data field can hold one piece of 
data (known as a value).

Data field: A data field (or field) is the basic building block of a record. Each record is made up 
of one or more data fields, and each data field can hold one piece of data (known as a value). A 
customer record in a typical customer mailing list Database might contain data fields similar to 
these: Name, Address, City, State, Zip, Phone, Fax. A data field can be empty or contain a 
value. Data field data is generally displayed or printed in Columns in the Details section of a 
report.

Data Source: A data source is a database, table, query, dictionary, or stored procedure result set 
that provides the data for a report.

Data types: A data type is a classification of the data that appears in a field or formula. Each 
piece of data used in a report or formula has one of the following data types: string, currency, 
number, date, date/time, time, or Boolean (TRUE/FALSE). It is important to understand data 
types because each function and operator works with only a limited number of data types (often 
as few as one). For some operators (+ and - for example), the program uses a different set of 
calculation rules for one type of data than it uses for another.

Debug: Eliminating errors that occur when you run a formula.

Default: A default is a pre-loaded response to a software request for data. It is the response the 
computer accepts automatically if you do not enter different data.

Details area: A collection of one or more Details sections (i.e., Details A, Details B, etc.).
June 2001 47
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Details section: The Details section of a report is the core section of the report. You structure the 
report in this section by inserting Data field, formulas, and other report elements.

Dictionary: A one-stop, ready-to-use source of data that is usually created for end users by 
computer professionals within the organization. The dictionary takes away the need for the end 
user to search multiple databases, struggle with links, build formulas, and decode cryptic field 
names. The user just selects the data he or she needs from the dictionary and builds the report.

Drag: Drag can mean different things, depending on the context in which the word is used:

!When referring to moving a field, drag means to click the field frame and, while keeping the 
mouse button pressed, move the frame to a new position. You release the mouse button when 
the field is in the desired position. 

!When referring to resizing a field, drag means to click one of the field frame handles and, 
while keeping the mouse button pressed, make the field bigger or smaller. You release the 
button when the field is the desired size.

!When referring to formatting text, drag means to highlight text by moving the I-beam cursor 
across it while the mouse button is pressed. You release the button when you have finished 
highlighting.

E
Element: The word element is used in the documentation to describe individual report 
components such as database fields, formulas, and group fields. The Design Tab uses 
rectangular frames to represent fields.

Expert: Seagate Crystal Reports offers you several Experts. Experts are tools designed to take 
you step-by-step through various aspects of report creation. In most cases Experts have a series 
of numbered tabs. Simply begin at step one and proceed through the steps. When you have 
completed the final step, the Expert will do the rest of the work. See Using Crystal Reports 
Experts Overview for more information.

Export: To export is to distribute your report to a disk file or through e-mail. Seagate Crystal 
Reports allows you to export your reports in many popular spreadsheet, database, word 
processor, HTML, and data interchange formats.

      Note: The term "Expert" in Seagate Crystal Reports is the 
equivalent of the term "Wizard" in Microsoft Access.
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